Single License

$25.00


Developer License

$200.00

Unlimited sites!

Updater 3.2.11

Modules

Updater makes updating ExpressionEngine and compatible Add-Ons easier then ever. Sick of uploading all your files, backing things up, moving files around and wasting hours of your life away? Updater is here to give you hours of your life back. Simply install Updater into ExpressionEngine modules and with a few simple clicks you will have ExpressionEngine up to date.

* Please note we will not support the actual update process, but just the install of Updater. If the update fails you will need to use the default EllisLab approved method.

Add-On Support

To view supported Add-Ons read here .


Features

  • Auto Update ExpressonEngine 2.1+
  • Auto Update Compatible Add-ons
  • Installs / Updates: EE Forum, EE MSM, CP Themes & Forum Themes
  • Backup Database
  • Backup Files
  • Visual Update Process

Requirements

  • Updater Requires ExpressionEngine 2.1+

Guaranteed to Work With The Following Add-Ons


Videos

Updater

What People Are Saying

"So @devdemon's add-on updater is simply awesome… updated EE and BR on my site in minutes - great job!" -@cwcrawley

"Okay, Updater is an absolute must buy! Updated my client's site in less than 30 secs. Amazing! @devdemon" -@fa6ian

"Wow. @DevDemon’s Updater add-on just saved me what would likely have been about an hour’s worth of work updating a site once for $15." -@onebrightlight

Updater 3.2.10

  • ADDED: EE 2.8 support

Updater 3.2.9

  • ADDED: Authenticaion Key to the settings page

Updater 3.2.8

  • IMPROVEMENT: Moved all XHR requests to the ACT URL

Updater 3.2.7

  • IMPROVEMENT: Better EE 2.7 support (addon install/update & XID issues)

Updater 3.2.6

  • IMPROVEMENT: EE 2.7 support
  • BUG: A PHP error would occur if the config.php was not formatted correctly

Updater 3.2.5

  • BUG: Some installations loaded the extension library twice

Updater 3.2.4

  • BUG: Some systems could not load the localize library

Updater 3.2.3

  • IMPROVEMENT: Language improvements
  • IMPROVEMENT: Updated SFTP library
  • BUG: PHP error when updating an ACC

Updater 3.2.2

  • IMPROVEMENT: create a htaccess inside of the backup dir itself
  • BUG: In some rare cases only the first Update routine was executed

Updater 3.2.1

  • BUG: On certain installs the Updater library could not find addons.php
  • BUG: PHP error when updating Accesory version

Updater 3.2.0

  • ADDED: Updater can now install/update: EE Forum, EE MSM, CP Themes & Forum Themes
  • ADDED: Addon & ExpressionEngine functions are now on one single page
  • ADDED: Updating EE now transfers the EE files first.
  • ADDED: Complete rewrite of client side javascript to be more robust and faster
  • ADDED: Drag & Drop file uploads
  • ADDED: Upload progress
  • ADDED: Updater now supports EE 2.1.0 again
  • ADDED: Automatic login check for FTP & SFTP transfer methods.
  • ADDED: Ability to browse the server to set your Path Mappings
  • ADDED: UI for public key authentication settings for SFTP.
  • IMPROVED: Removed php_zip extension requirement

Updater 3.1.8

  • ADDED: Support for EE 2.6.0
  • ADDED: Support for key based authentication for SFTP transfer methods
  • ADDED: Options for disabling menubar links
  • IMPROVED: Better Addon name detection

Updater 3.1.7

  • ADDED: Support for servers who in some cases don't detect PATH_INFO correctly
  • ADDED: If native modules are deleted or native theme dirs, Updater will not add them back when updating ExpressionEngine
  • CHANGED: Addon Install/Update detection improved.
  • CHANGED: Added Anonymous Statistics, which can be disabled via the settings page

Updater 3.1.6

  • ADDED: Retry button for ExpressionEngine Updates (Wait Server stage might not be 100% cleared)
  • ADDED: Config item to disable/enable dynamic memory increase
  • ADDED: Support for database_backup_required() in upd.addon.php (param = current_version, return bool)
  • ADDED: Support for update_notes key in package.json

Updater 3.1.5

  • CHANGED: For now Updater will skip updating third party modules. Just first party modules now.

Updater 3.1.4

  • ADDED: Support for EE 'cache_path' config override
  • CHANGED: Improved server response checking for local MAMP installs

Updater 3.1.3

  • ADDED: htaccess to backup directory
  • CHANGED: Checking for server response wouldn't work if the server used a different PATH_INFO

Updater 3.1.2

  • ADDED: Descriptive error message when the installer directory still exists.
  • ADDED: EE update MySQL error will now be catched and displayed.
  • ADDED: Module updates after copying new EE files

Updater 3.1.1

  • ADDED: All AJAX requests are now passed through the CP to prevent XHR errors.

Updater 3.1.0

  • ADDED: Almost 90% compatibility with addons that follow directory structure (version detection is disabled when needed)
  • ADDED: Records & Displays executed SQL Queries
  • ADDED: AJAX warning message
  • ADDED: Settings warning message
  • BUG: paths that included / would fail to upload

Updater 3.0.1

  • CHANGE: Updater now merges directories instead of rename/delete. (Forum/MSM/override.css compatibility)

Updater 3.0.0

  • ADDED: SFTP Support
  • ADDED: FTP Support (beta)
  • ADDED: Path Mapping in Settings Page
  • ADDED: Support for multiple addons
  • ADDED: Support for addon file url & ee file url
  • ADDED: Settings check in requirements sections
  • ADDED: Check settings button on all pages
  • ADDED: AJAX Error viewer
  • ADDED: More descriptive error messages!
  • ADDED: Addon package.json routines support
  • ADDED: Compatbility with more addons
  • ADDED: Progressbar while backuping files
  • ADDED: Progressbar while copying new EE files
  • CHANGE: Requirements section is only shown when a condition is not met

Updater 2.0.5

  • ADDED: Settings page that allows you to change backup location
  • ADDED: Extra check for write permissions in system dir
  • BUG: Site was not properly being turned on back online after EE install.

Currently no tutorials for this product.

Currently no troubleshooting documents for this product.